欢迎来到羊毛财经网!
阅读排行
您的位置:首页>炒股技巧 >

美丽彩福星送福指标(主图 通达信 贴图)公式加了帮助笔墨信号下载_通达信公式

2020-05-21 09:26:38
原标题:美丽彩福星送福指标(主图 通达信 贴图)公式加了帮助笔墨信号下载

美丽彩福星送福指标(主图 通达信 贴图)公式加了帮助笔墨信号源码下载:

 赤色做多, 绿色做空,  同时添加了一些帮助笔墨信号。 
 

 N1:=13;
VAR1:=REF(C,1);
VAR2:=SMA(MAX(C-VAR1,0),N1,  1)/SMA(ABS(C-VAR1),  N1,1)*1000;
VAR3:=DRAWLINE(VAR2>=HHV(VAR2,N1), VAR2,   VAR2<=LLV(VAR2, N1),VAR2,1);
VAR4:=VAR2=VAR3;
VAR5:=VAR2<REF(VAR2,1);
RSV:=(C-LLV(L, 25))/(HHV(HIGH,  25)-LLV(L, 25))*100;
K:=SMA(RSV, 4, 1);
D:=SMA(K,4, 1);
J:=4*K-2*D;
VAR6:=(2*C+H+L)/4;{可将3该为4, 信号少点}
VAR7:=EMA(EMA(EMA(VAR6,  4),4),  4);{可将3该为4,信号少点}
VAR8:=(VAR7-REF(VAR7, 1))/REF(VAR7,1)*100;
VAR9:=MA(VAR8, 4)+0.03;
VAR10:=MA(VAR8,1);
KB:=EMA(C,4)-EMA(C, 18);
DB:=EMA(KB,  4);
AA:=BARSCOUNT(C);
AH:=HHV(H, 120);
AL:=LLV(L,  120);
A0:=(AH-AL)/30;
VAR2S:=(2*CLOSE+HIGH+LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2, 0,1);
VAR4S:=LLV(LOW, 5); VAR5S:=HHV(HIGH, 4);
散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100, 4)*VAR3S;
庄家:=EMA(0.667*REF(散户,  1)+0.333*散户, 2)*VAR3S;
STICKLINE(KB<DB AND DB<REF(DB,  1), C,OPEN,3.2, 0),COLOR004400;
STICKLINE(KB<DB AND DB<REF(DB, 1),C,  OPEN, 2.7,  0),COLOR006600;
STICKLINE(KB<DB AND DB<REF(DB, 1),C, OPEN,   2.1,0), COLOR008800;
STICKLINE(KB<DB AND DB<REF(DB, 1),  C,  OPEN, 1.5,0), COLOR00AA00;
STICKLINE(KB<DB AND DB<REF(DB,1), C, OPEN, 0.9, 0), COLOR00CC00;
STICKLINE(KB<DB AND DB<REF(DB,   1),C,OPEN,   0.3,0), COLOR00EE00;
STICKLINE(KB>DB AND DB>REF(DB,1),C, OPEN,3.2,  0),COLOR000055;
STICKLINE(KB>DB AND DB>REF(DB, 1), C,    OPEN, 2.7, 0),  COLOR000077;
STICKLINE(KB>DB AND DB>REF(DB,   1), C, OPEN,  2.1, 0), COLOR000099;
STICKLINE(KB>DB AND DB>REF(DB, 1), C, OPEN, 1.5,0),  COLOR0000BB;
STICKLINE(KB>DB AND DB>REF(DB, 1),  C,OPEN,0.9,0),COLOR0000DD;
STICKLINE(KB>DB AND DB>REF(DB,1), C, OPEN,  0.3, 0), COLOR0000FF;
STICKLINE(CROSS(VAR9, VAR10) AND J>65,H,  OPEN,3.15,0), COLORAA1100;
STICKLINE(CROSS(VAR9, VAR10) AND J>65,  H, OPEN,  2.45,   0),COLORAA3300;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,  OPEN,   1.75, 0),  COLORAA5500;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN, 1.05, 0), COLORAA7700;
STICKLINE(CROSS(VAR9,  VAR10) AND J>65,  H,  OPEN, 0.35,0), COLORAA9900;
STICKLINE(VAR4 AND VAR5,   L,   OPEN, 3.15,   0),COLOR1111FF;
STICKLINE(VAR4 AND VAR5,L, OPEN,2.45,0),  COLOR3333FF;
STICKLINE(VAR4 AND VAR5,L,  OPEN,  1.75,0),COLOR5555FF;
STICKLINE(VAR4 AND VAR5,  L, OPEN, 1.05,  0),COLOR7777FF;
STICKLINE(VAR4 AND VAR5,  L,  OPEN,   0.35,  0), COLOR9999FF;
STICKLINE(CROSS(散户,  庄家) AND 散户<30, L, OPEN,3.15, 0),COLOR770077;
STICKLINE(CROSS(散户, 庄家) AND 散户<30, L,OPEN,2.45, 0), COLOR990099;
STICKLINE(CROSS(散户, 庄家) AND 散户<30,L, OPEN, 1.75, 0),COLORBB00BB;
STICKLINE(CROSS(散户,   庄家) AND 散户<30,L, OPEN,  1.05, 0), COLORDD00DD;
STICKLINE(CROSS(散户, 庄家) AND 散户<30, L, OPEN, 0.35, 0), COLORFF00FF;
STICKLINE(CROSS(0.9, 1/VOL*1000>0.01 AND "KDJ.J"<0),  L,  OPEN,3.15, 0), COLOR337777;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0), L, OPEN,  2.45, 0), COLOR339999;
STICKLINE(CROSS(0.9,  1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN, 1.75, 0), COLOR33BBBB;
STICKLINE(CROSS(0.9, 1/VOL*1000>0.01 AND "KDJ.J"<0),L, OPEN, 1.05,  0),  COLOR33DDDD;
STICKLINE(CROSS(0.9,  1/VOL*1000>0.01 AND "KDJ.J"<0),L, OPEN, 0.35, 0), COLOR33FFFF;
STICKLINE((AA+0)/34=FLOOR((AA+0)/34),  L,  OPEN,3.15,1), COLORFFFFFF;
DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),L*1, '福星护航'), COLORFFFFFF;
{第一股票公式网-最好的股票公式网站 www.cHnMoNey.Com}
DRAWTEXT(CROSS(散户, 庄家) AND 散户<30,L*1,'吃'),COLORFF00FF;
DRAWICON(CROSS(VAR9,VAR10) AND J>65, H*1,15),  COLORGREEN;
DRAWTEXT(CROSS(VAR9,VAR10) AND J>65,H*1,' 送福'),COLORYELLOW;
DRAWICON(VAR4 AND VAR5, L*1,  9);
DRAWTEXT(VAR4 AND VAR5, L*1, ' 福')COLORFFFFFF;
DRAWTEXT(CROSS(0.9,   1/VOL*1000>0.01 AND "KDJ.J"<0), L*1,  '赢利钱'),  COLOR33FFFF;
B1:=MA(C, 1);
B2:=SMA(SMA(SMA(B1,2,1),  2, 1), 2, 1);
SMA2:=MA(B2,   3);
福星下限:IF(LLV(MA(B2, 8),3)<B2,   LLV(MA(B2, 8), 3), B2);
IF(B2>SMA2,  B2,   DRAWNULL),  COLORRED, LINETHICK4;
IF(B2<SMA2,  B2,  DRAWNULL), COLORGREEN,LINETHICK4;
SNAKEA:HHV(MA(B2,1),  13),  COLORYELLOW;
VAR1A:=(2*CLOSE+HIGH+LOW)/4;
VAR2A:=MA(VAR1A,7);
VAR3A:=VAR2A-MA(VAR1A, 7/2)<0;
VAR4A:=VAR2A-MA(VAR1A,  7/2)>0;
VAR5A:=BARSLAST(VAR3A);
VAR6A:=0-BARSLAST(VAR4A);
VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
STICKLINE(SNAKEA>SMA2 AND B2<SMA2,SNAKEA, SMA2,0,   0),  COLORBLUE;
VAR11A:=(CLOSE*2+HIGH+LOW)/4;
VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);
VAR31A:=EMA(VAR21A, 5);
VARA:=((REF(VAR9,  1) AND (CLOSE >= REF(CLOSE,  1))) AND (CLOSE <= REF(CLOSE, 2)));
VARB:=((REF(VARA,   1) AND (CLOSE <= REF(CLOSE, 1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB, 1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,  2)));
VARD:=((REF(VARC, 1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,   2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,  2)));
VARF:=((REF(VARE, 1) AND (CLOSE >= REF(CLOSE,   1))) AND (CLOSE <= REF(CLOSE, 2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE, 1))) AND (CLOSE <= REF(CLOSE, 2)));
VAR12:=((REF(VAR11,  1) AND (CLOSE <= REF(CLOSE,  1))) AND (CLOSE >= REF(CLOSE, 2)));
VAR13:=((REF(VAR12,  1) AND (CLOSE >= REF(CLOSE, 1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,  1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE, 2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,  2)));
VAR16:=((REF(VAR15, 1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,   2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,  1))) AND (CLOSE <= REF(CLOSE, 2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,  2)));
VAR19:=((REF(VAR18, 1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,  2)));
VAR1B:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19), 1) AND VAR2);
A13:=EMA(CLOSE, 55);
A14:=MA(CLOSE,75);
A15:=EMA(A14,  3);
A16:=EMA(A15, 3);
A17:=(HIGH + LOW) / 5;
A18:=(MA(A17, 4)) - (MA(A17,34));
A19:=CROSS(A18,0);
A20:=CROSS(0, A18);
A21:=BARSLAST(A19);
A22:=BARSLAST(A20);
A23:=REF(A19,   1);
A24:=REF(A20, 1);
A25:=BARSLAST(A23);
A26:=BARSLAST(A24);
A27:=IF((A25 < A26),   (REF((HHV(HIGH,2)),A25)),  (REF((LLV(LOW,  2)), A26)));
A28:=(((REF(CLOSE, 1)) <= (REF(A27, 1))) AND (CLOSE > A27)) AND (A21 < A22);
A29:=(((REF(CLOSE, 1)) >= (REF(A27,  1))) AND (CLOSE < A27)) AND (A22 < A21);
A30:=A28 AND ((COUNT(A28,   A21)) = 1);
A31:=A29 AND ((COUNT(A29,A22)) = 1);
A32:=A30 AND ((REF(BARSLAST(A31),1)) < (REF(BARSLAST(A30),1)));
A33:=A31 AND ((REF(BARSLAST(A31), 1)) > (REF(BARSLAST(A30),1)));
AC:=AMOUNT/(VOL);
YY:=MA(AC, 13);
LLL:=(C-YY)/YY*100;
MIDC := MA(CLOSE,22);
UPPERC:= MIDC + 2*STD(C, 22);
LOWERC:= MIDC - 2*STD(C,  22);
BBA:=(C-LOWERC)/(UPPERC-LOWERC);
BBC:=FORCAST(BBA, 3);
LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA, 1)<0 AND LLL>REF(LLL, 1));
 

漂亮彩福星送福指标(主图 通达信 贴图)公式加了辅助文字信号

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。